import Foundation
let pattern = #"(?i)(?<!\b[01][0-9])(?<!\b[2][0-3])([^\S\r\n]*:)[^\S\r\n]*(?![0-5][0-9](?:[ap]\.?m\b\.?)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
am
pm
P.M.
10:56pm : start a new line
10:43 a.m.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)