// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^120/BHP\d/(?P<lblreq_board>LBLREQ)-(?P<lblreq_id>\d+)/(?P<mission>\d{4}-\d{2}-\d{2}-Z0F\d{4})/(?P<run>\d+)/(?P<vehicle_time>\d{18})/(?P<event_time_s>\d+\.\d+)/(?:sweep_dir_\d+/sweep_\d+/)?image_(?P<channel>[a-z_]+)_000000000\.png$").unwrap();
let string = "120/BHP4/LBLREQ-92/2018-06-13-Z0F0034/2/347742483826079513/315970791.448747000/sweep_dir_0/sweep_0/image_raw_ring_front_center_000000000.png
120/BHP4/LBLREQ-99/2018-07-05-Z0F0026/2/305006254539769513/315967941.329407000/sweep_dir_0/sweep_0/image_raw_stereo_front_left_000000000.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}