use strict;
my $str = 'https://www.rover.com/search/?utm_medium=email&utm_source=Responsys&utm_campaign=111017190001&utm_content=2017_11_09_O_TGiving_NoSt_SDTest_NoCoup_2&utm_term=111017';
my $regex = qr/(?P<utm_content>(?<=utm_content=).*?(?=&|\\s|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}