#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\s|^)(?s)\d{1,3}+\/+\s+.*?(?=\d+\/+\s+|$)"
Local $sString = "1/ This is a string and it " & @CRLF & _
"has some text on a new line" & @CRLF & _
"2/ And then there's another string that has text only on one line" & @CRLF & _
"532/ Another string that has some year on a new line" & @CRLF & _
"2020/xyz followed by some letters" & @CRLF & _
"721/ And this is the last line "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")