import re
regex = re.compile(r"(\s|^)(?s)\d{1,3}+\/+\s+.*?(?=\d+\/+\s+|$)", flags=re.MULTILINE)
test_str = ("1/ This is a string and it \n"
"has some text on a new line\n"
"2/ And then there's another string that has text only on one line\n"
"532/ Another string that has some year on a new line\n"
"2020/xyz followed by some letters\n"
"721/ And this is the last line ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")