re = /(\s|^)(?s)\d{1,3}+\/+\s+.*?(?=\d+\/+\s+|$)/m
str = '1/ This is a string and it
has some text on a new line
2/ And then there\'s another string that has text only on one line
532/ Another string that has some year on a new line
2020/xyz followed by some letters
721/ And this is the last line '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end