# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([A-Z0-9])(?:([A-Z0-9\.\-\s]*)*\:+)"
test_str = ("MR. SMITH:\n"
"- CAPTAIN AMERICA:\n"
"ANT-MAN:\n"
"2014 NEBULA:\n"
"-2012 IRON MAN:\n"
"BOY 1:\n\n"
"1\n"
"00:00:07,174 --> 00:00:09,837\n"
"BARTON: Okay, hold on.\n\n"
"16\n"
"00:00:36,411 --> 00:00:37,527\n"
"- COOPER: Nice!\n"
"- LAURA: Nice throw, kiddo.\n")
subst = "\\<font color\\=\\\"\\#FFA500\\\"\\>\\<b\\>$0\\<\\/b\\>\\<\\/font\\>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.