#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*randomwebsite\.com.*)lowquality(.*\.png)"
Local $sString = "https://randomwebsite.com/gallery/randomstring124/lowquality/imagename.png"
Local $sSubst = "$1highquality$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)