using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*randomwebsite\.com.*)lowquality(.*\.png)";
string substitution = @"$1highquality$2";
string input = @"https://randomwebsite.com/gallery/randomstring124/lowquality/imagename.png";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}