using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?href=(""|')(.*?)(""|').*?>(.*?)<\/a>\s(.*)";
string input = @"<a href=""https://www.catholicgallery.org/bible-drb/acts-9/"">Acts 9:</a> 1-20
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}