package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a.*?href=("|')(.*?)("|').*?>(.*?)<\/a>\s(.*)`)
var str = `<a href="https://www.catholicgallery.org/bible-drb/acts-9/">Acts 9:</a> 1-20
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}