// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a.*?href=("|')(.*?)("|').*?>(.*?)<\/a>\s(.*)"#).unwrap();
let string = "<a href=\"https://www.catholicgallery.org/bible-drb/acts-9/\">Acts 9:</a> 1-20
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}