re = /\b(LLC|CO|CORP|DIV)\b/m
str = ' TEST LLC TEST CO TEST CORP TEST DIV
COMPUTING DEVICES CO DIV CLDC '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end