import re
regex = re.compile(r"(?:\")([1-9]\d{0,2}(?:,\d{3}){2,}|[1-9]\d{1,2},\d{3})(?:\")", flags=re.MULTILINE)
test_str = "\"10,400,000\",\"10,900,000\",\"500,000\",\"1,400,000\",\"1,900,000,123,564\",\"50,000\",\",050,000\",\"50,00000\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")