$re = '/^project\(\n\s+[^\n]+\n\s+version:\s+\'([^\']+)\',\n/s';
$str = 'project(
\'waybar\', \'cpp\', \'c\',
version: \'0.9.20\',
license: \'MIT\',
meson_version: \'>= 0.50.0\',
default_options : [
\'cpp_std=c++20\',
\'buildtype=release\',
\'default_library=static\'
],
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);