#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\.+(?<stringOfInterest>.*)"
Local $sString = ".. Adobe Flash Player ActiveX DSC " & @CRLF & _
"... Adobe Flash Player NPAPI" & @CRLF & _
"... Adobe Reader XI (..) " & @CRLF & _
".. Adobe Shockwave Player " & @CRLF & _
"... Atmel Touchscreen Power " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")