use strict;
my $str = '.. Adobe Flash Player ActiveX DSC
... Adobe Flash Player NPAPI
... Adobe Reader XI (..)
.. Adobe Shockwave Player
... Atmel Touchscreen Power
';
my $regex = qr/\.+(?<stringOfInterest>.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}