package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1[3-9]你好\d{1,9}去$`)
var str = `abcdefg1234567890
你好
19你好83489去
14你好2去
19你好807974919去
23你好787361898去
18你好378972939去
12你好837834659去
18你好747593638去`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}