use strict;
my $str = 'abcdefg1234567890
你好
19你好83489去
14你好2去
19你好807974919去
23你好787361898去
18你好378972939去
12你好837834659去
18你好747593638去';
my $regex = qr/^1[3-9]你好\d{1,9}去$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}