^start of line
1the literal 1 (4910 / 618 / 3116)
3-9one character from 3 (5110) to 9 (5710)
\d{1,9}a digit, repeated between 1 and 9 times
去the literal 去 (2143510 / 516738 / 53BB16)
$end of line
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string