use strict;
my $str = 'm-0-o.bfe-nfk@s-ugd-og.gg-gm-ain.com.pl
wfff-ef-ff.mi-ki.fi-ki.miki@dns1-su-ddd.o-ma.in.dom-ain.kkk
max-io.be-nko@sub-dom-ain.dom-ain.com.pl
#ver. 6
^((([a-z0-9]+[\\-]{0,1})+[a-z0-9]+?\\.)+[a-z0-9][a-z0-9|\\-]+[a-z0-9])@([a-z0-9]+[\\-|\\.]{0,1}[a-z0-9])+(.[a-z0-9]{2,})+$
#ver. 5
^([a-z0-9][a-z0-9|\\-]+[a-z0-9]{1,}?\\.)+[a-z0-9|\\-]+[a-z0-9]@([a-z0-9][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[a-z0-9](.[a-z0-9]{2,})+)$
#ver. 4
^[\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w]@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$
# ver. 3
^[a-z0-9\\-\\.]+@([\\w][a-z0-9|\\-]+?\\.[a-z0-9|\\-]+[\\w](.[a-z0-9]{2,})+)$
#ver. 2
^[a-z0-9\\-\\.]+@[a-z0-9|\\-]+?\\.[a-z0-9|\\-]+(.[a-z0-9]{2,})+$
#ver. 1
^([\\w\\.\\-]+)@([\\w\\-]+)((\\.(\\w){2,3})+)$';
my $regex = qr/^((([a-z0-9]+[\-]{0,1})+[a-z0-9]+?\.)+[a-z0-9][a-z0-9|\-]+[a-z0-9])@([a-z0-9]+[\-|\.]{0,1}[a-z0-9]+)+(.[a-z0-9]{2,})+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}