$re = '/(?<=([aui]))[wy](?=\1)|(?<=i)[wy](?=u)/';
$str = 'asdawasda
asdayasda
asdiwisda
asdiyisda
asduwusda
asduyusda
asdawisda
asdawusda
asdayisda
asdayusda
asdiwasda
asdiwusda
asdiyasda
asdiyusda
asduwasda
asduwisda
asduyasda
asduyisda
ramiyun
da9iwun';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;