re = /(?<=([aui]))[wy](?=\1)|(?<=i)[wy](?=u)/
str = 'asdawasda
asdayasda
asdiwisda
asdiyisda
asduwusda
asduyusda
asdawisda
asdawusda
asdayisda
asdayusda
asdiwasda
asdiwusda
asdiyasda
asdiyusda
asduwasda
asduwisda
asduyasda
asduyisda
ramiyun
da9iwun'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result