re = /^((.*?)(\w+)( +\w+)*(\s|.*?))$/m
str = 'smith john go home your shift getting over in the 30 minute later then why you here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end