using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"bar0(?![|])";
string input = @"1) Search matches in the foobar0 - matches should be found
2) Search matches in the foobar0| - matches should be not found
3) Search matches in the foobar0|0 - matches should be not found
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}