const regex = /1[3-4]{1}[0-9]{2}\/[0-1]{1}[0-9]{1}\/[0-3]{1}[0-9]{1}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1[3-4]{1}[0-9]{2}\\\/[0-1]{1}[0-9]{1}\\\/[0-3]{1}[0-9]{1}', 'g')
const str = `1374/11/10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}