using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a?)?:\w+:(\d{18}>)?|(\u00a9|\u00ae|[\u2000-\u3300]|\ud83c[\ud000-\udfff]|\ud83d[\ud000-\udfff]|\ud83e[\ud000-\udfff])";
string input = @"<:custom_emoji:652867697494720533>
<a:animated_custom_emoji:741032442814791702>
:smiley:
😀
Lorem Ipsum dolor sit amet...
123456789";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}