const regex = /(<a?)?:\w+:(\d{18}>)?|(\u00a9|\u00ae|[\u2000-\u3300]|\ud83c[\ud000-\udfff]|\ud83d[\ud000-\udfff]|\ud83e[\ud000-\udfff])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a?)?:\\w+:(\\d{18}>)?|(\\u00a9|\\u00ae|[\\u2000-\\u3300]|\\ud83c[\\ud000-\\udfff]|\\ud83d[\\ud000-\\udfff]|\\ud83e[\\ud000-\\udfff])', 'g')
const str = `<:custom_emoji:652867697494720533>
<a:animated_custom_emoji:741032442814791702>
:smiley:
😀
Lorem Ipsum dolor sit amet...
123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}