# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<startDay>\d{2})[\s|](?P<finishDay>\d{2})[\s|](?:del|de[\s|]el|de )[\s|](?P<month>\d{2})[\s|](?:del|de[\s|]el|de)[\s|](?P<year>\d*)"
test_str = ("05 del 07 del 2000 del 09 hhggh\" #example 0 - Not modify!\n"
"04 del 05 del 07 del 2000\" #example 1 - Not modify!\n"
"04 05 del 06 de 200\" #example 2 - Yes modify!\n"
"04 05 del 06 de 20076 55\" #example 3 - Yes modify!")
subst = "\\g<startDay> \\g<finishDay>-\\g<month>-\\g<year>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.