import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "motive=\"(.+?)\" res=\"(\\d+/\\d+)/(\\d+)\"";
final String string = "<ok date=\"1578334440\" motive=\"1.5.4. Невыплата штрафа\" res=\"21/8000/1214657702\" udo=\"0/0\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}