const regex = new RegExp('motive="(.+?)" res="(\\d+/\\d+)/(\\d+)"', 'gm')
const str = `<ok date="1578334440" motive="1.5.4. Невыплата штрафа" res="21/8000/1214657702" udo="0/0" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}