// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)motive="(.+?)" res="(\d+/\d+)/(\d+)""#).unwrap();
let string = "<ok date=\"1578334440\" motive=\"1.5.4. Невыплата штрафа\" res=\"21/8000/1214657702\" udo=\"0/0\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}