# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(BB(?:\|\d){4,6}\|[^\s|]{3}\|[^\s|]{4}\|)9{2,9}\|9{2,9}(?!\d)"
test_str = ("XX=BB|3|3|1|1|PLP|KLWE|9999|9999\n"
"XX=BB|3|3|1|1|2|PLP|KPOK|99999|99999\n"
"999|999|999|9999|999")
subst = "\\g<1>12|21"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.