import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\?v=(.+?)&.+";
final String string = "https://www.youtube.com/watch?v=SEkUienM2oY&t=1265s\n"
+ "https://m.youtube.com/watch?v=SEkUienM2oY&t=1265s\n\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}