$re = '/^!(\w+):([\w-]+):(\w+)$/i';
$str = '!toto120:abc-DEF:tqp34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);