use strict;
my $str = 'Detect
https://stackoverflow.com/%22Abcde3FGhiDE%22Zyx23
|a|b|c|AbcdEFGH123|456Ac
P A Abcde3Dd3FGhiDE Z H
ZZ123!Abcde3FGhiDE!123
Don\'t detect
IAMoverTHELIMITTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT3
NULLLLLLLLLLLLLLLLLLLLLLllll
|A|b|c|D|E|F|1|
<HeLLoWoRlD"123
';
my $regex = qr/(?=(?:\d*[A-Za-z]))(?=(?:\S*?[A-Z]){3,}\S*?$)(?=(?:[a-zA-Z]*\d))[A-Za-z0-9]{5,30}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}