#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "car (?=apple|apple apple|apple banana|apple carrot|apple doormat|apple elephant|apple frankfurter|apple gelatin|apple humus|apple indiana|apple joseph|apple kayak|apple letter|apple meal|apple nope|apple orange|apple pie|apple quick|apple rest|apple sort|apple this|apple under|apple view|apple with|apple xerox|apple yes|apple zap|banana|banana apple|banana banana|banana carrot|banana doormat|banana elephant|banana frankfurter|banana gelatin|banana humus|banana indiana|banana joseph|banana kayak|banana letter|banana meal|banana nope|banana orange|banana pie|banana quick|banana rest|banana sort|banana this|banana under|banana view|banana with|banana xerox|banana yes|banana zap|carrot|carrot apple|carrot banana|carrot carrot|carrot doormat|carrot elephant|carrot frankfurter|carrot gelatin|carrot humus|carrot indiana|carrot joseph|carrot kayak|carrot letter|carrot meal|carrot nope|carrot orange|carrot pie|carrot quick|carrot rest|carrot sort|carrot this|carrot under|carrot view|carrot with|carrot xerox|carrot yes|carrot zap|doormat|doormat apple|doormat banana|doormat carrot|doormat doormat|doormat elephant|doormat frankfurter|doormat gelatin|doormat humus|doormat indiana|doormat joseph|doormat kayak|doormat letter|doormat meal|doormat nope|doormat orange|doormat pie|doormat quick|doormat rest|doormat sort|doormat this|doormat under|doormat view|doormat with|doormat xerox|doormat yes|doormat zap|elephant|elephant apple|elephant banana|elephant carrot|elephant doormat|elephant elephant|elephant frankfurter|elephant gelatin|elephant humus|elephant indiana|elephant joseph|elephant kayak|elephant letter|elephant meal|elephant nope|elephant orange|elephant pie|elephant quick|elephant rest|elephant sort|elephant this|elephant under|elephant view|elephant with|elephant xerox|elephant yes|elephant zap|frankfurter|frankfurter apple|frankfurter banana|frankfurter carrot|frankfurter doormat|frankfurter elephant|frankfurter frankfurter|frankfurter gelatin|frankfurter humus|frankfurter indiana|frankfurter joseph|frankfurter kayak|frankfurter letter|frankfurter meal|frankfurter nope|frankfurter orange|frankfurter pie|frankfurter quick|frankfurter rest|frankfurter sort|frankfurter this|frankfurter under|frankfurter view|frankfurter with|frankfurter xerox|frankfurter yes|frankfurter zap|gelatin|gelatin apple|gelatin banana|gelatin carrot|gelatin doormat|gelatin elephant|gelatin frankfurter|gelatin gelatin|gelatin humus|gelatin indiana|gelatin joseph|gelatin kayak|gelatin letter|gelatin meal|gelatin nope|gelatin orange|gelatin pie|gelatin quick|gelatin rest|gelatin sort|gelatin this|gelatin under|gelatin view|gelatin with|gelatin xerox|gelatin yes|gelatin zap|humus|humus apple|humus banana|humus carrot|humus doormat|humus elephant|humus frankfurter|humus gelatin|humus humus|humus indiana|humus joseph|humus kayak|humus letter|humus meal|humus nope|humus orange|humus pie|humus quick|humus rest|humus sort|humus this|humus under|humus view|humus with|humus xerox|humus yes|humus zap|indiana|indiana apple|indiana banana|indiana carrot|indiana doormat|indiana elephant|indiana frankfurter|indiana gelatin|indiana humus|indiana indiana|indiana joseph|indiana kayak|indiana letter|indiana meal|indiana nope|indiana orange|indiana pie|indiana quick|indiana rest|indiana sort|indiana this|indiana under|indiana view|indiana with|indiana xerox|indiana yes|indiana zap|joseph|joseph apple|joseph banana|joseph carrot|joseph doormat|joseph elephant|joseph frankfurter|joseph gelatin|joseph humus|joseph indiana|joseph joseph|joseph kayak|joseph letter|joseph meal|joseph nope|joseph orange|joseph pie|joseph quick|joseph rest|joseph sort|joseph this|joseph under|joseph view|joseph with|joseph xerox|joseph yes|joseph zap|kayak|kayak apple|kayak banana|kayak carrot|kayak doormat|kayak elephant|kayak frankfurter|kayak gelatin|kayak humus|kayak indiana|kayak joseph|kayak kayak|kayak letter|kayak meal|kayak nope|kayak orange|kayak pie|kayak quick|kayak rest|kayak sort|kayak this|kayak under|kayak view|kayak with|kayak xerox|kayak yes|kayak zap|letter|letter apple|letter banana|letter carrot|letter doormat|letter elephant|letter frankfurter|letter gelatin|letter humus|letter indiana|letter joseph|letter kayak|letter letter|letter meal|letter nope|letter orange|letter pie|letter quick|letter rest|letter sort|letter this|letter under|letter view|letter with|letter xerox|letter yes|letter zap|meal|meal apple|meal banana|meal carrot|meal doormat|meal elephant|meal frankfurter|meal gelatin|meal humus|meal indiana|meal joseph|meal kayak|meal letter|meal meal|meal nope|meal orange|meal pie|meal quick|meal rest|meal sort|meal this|meal under|meal view|meal with|meal xerox|meal yes|meal zap|nope|nope apple|nope banana|nope carrot|nope doormat|nope elephant|nope frankfurter|nope gelatin|nope humus|nope indiana|nope joseph|nope kayak|nope letter|nope meal|nope nope|nope orange|nope pie|nope quick|nope rest|nope sort|nope this|nope under|nope view|nope with|nope xerox|nope yes|nope zap|orange|orange apple|orange banana|orange carrot|orange doormat|orange elephant|orange frankfurter|orange gelatin|orange humus|orange indiana|orange joseph|orange kayak|orange letter|orange meal|orange nope|orange orange|orange pie|orange quick|orange rest|orange sort|orange this|orange under|orange view|orange with|orange xerox|orange yes|orange zap|pie|pie apple|pie banana|pie carrot|pie doormat|pie elephant|pie frankfurter|pie gelatin|pie humus|pie indiana|pie joseph|pie kayak|pie letter|pie meal|pie nope|pie orange|pie pie|pie quick|pie rest|pie sort|pie this|pie under|pie view|pie with|pie xerox|pie yes|pie zap|quick|quick apple|quick banana|quick carrot|quick doormat|quick elephant|quick frankfurter|quick gelatin|quick humus|quick indiana|quick joseph|quick kayak|quick letter|quick meal|quick nope|quick orange|quick pie|quick quick|quick rest|quick sort|quick this|quick under|quick view|quick with|quick xerox|quick yes|quick zap|rest|rest apple|rest banana|rest carrot|rest doormat|rest elephant|rest frankfurter|rest gelatin|rest humus|rest indiana|rest joseph|rest kayak|rest letter|rest meal|rest nope|rest orange|rest pie|rest quick|rest rest|rest sort|rest this|rest under|rest view|rest with|rest xerox|rest yes|rest zap|sort|sort apple|sort banana|sort carrot|sort doormat|sort elephant|sort frankfurter|sort gelatin|sort humus|sort indiana|sort joseph|sort kayak|sort letter|sort meal|sort nope|sort orange|sort pie|sort quick|sort rest|sort sort|sort this|sort under|sort view|sort with|sort xerox|sort yes|sort zap|this|this apple|this banana|this carrot|this doormat|this elephant|this frankfurter|this gelatin|this humus|this indiana|this joseph|this kayak|this letter|this meal|this nope|this orange|this pie|this quick|this rest|this sort|this this|this under|this view|this with|this xerox|this yes|this zap|under|under apple|under banana|under carrot|under doormat|under elephant|under frankfurter|under gelatin|under humus|under indiana|under joseph|under kayak|under letter|under meal|under nope|under orange|under pie|under quick|under rest|under sort|under this|under under|under view|under with|under xerox|under yes|under zap|view|view apple|view banana|view carrot|view doormat|view elephant|view frankfurter|view gelatin|view humus|view indiana|view joseph|view kayak|view letter|view meal|view nope|view orange|view pie|view quick|view rest|view sort|view this|view under|view view|view with|view xerox|view yes|view zap|with|with apple|with banana|with carrot|with doormat|with elephant|with frankfurter|with gelatin|with humus|with indiana|with joseph|with kayak|with letter|with meal|with nope|with orange|with pie|with quick|with rest|with sort|with this|with under|with view|with with|with xerox|with yes|with zap|xerox|xerox apple|xerox banana|xerox carrot|xerox doormat|xerox elephant|xerox frankfurter|xerox gelatin|xerox humus|xerox indiana|xerox joseph|xerox kayak|xerox letter|xerox meal|xerox nope|xerox orange|xerox pie|xerox quick|xerox rest|xerox sort|xerox this|xerox under|xerox view|xerox with|xerox xerox|xerox yes|xerox zap|yes|yes apple|yes banana|yes carrot|yes doormat|yes elephant|yes frankfurter|yes gelatin|yes humus|yes indiana|yes joseph|yes kayak|yes letter|yes meal|yes nope|yes orange|yes pie|yes quick|yes rest|yes sort|yes this|yes under|yes view|yes with|yes xerox|yes yes|yes zap|zap|zap apple|zap banana|zap carrot|zap doormat|zap elephant|zap frankfurter|zap gelatin|zap humus|zap indiana|zap joseph|zap kayak|zap letter|zap meal|zap nope|zap orange|zap pie|zap quick|zap rest|zap sort|zap this|zap under|zap view|zap with|zap xerox|zap yes|zap zap)(.{31}|.{30}|.{29}|.{28}|.{27}|.{26}|.{25}|.{24}|.{23}|.{22}|.{21}|.{20}|.{19}|.{18}|.{17}|.{16}|.{15}|.{14}|.{13}|.{12}|.{11}|.{10}|.{9}|.{8}|.{7}|.{6}|.{5}|.{4}|.{3}|.{2}|.) crashed"
Local $sString = "car zap view crashed" & @CRLF & _
"car xerox elephant crashed" & @CRLF & _
"car zap crashed" & @CRLF & _
"car humus zap crashed" & @CRLF & _
"car yes banana crashed" & @CRLF & _
"car crashed" & @CRLF & _
"^ the above shouldn't match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")