#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!^)(?=(?:\d{3})+(?!\.|\d))"
Local $sString = "123456789123456789123456789" & @CRLF & _
"123456789" & @CRLF & _
"1234567" & @CRLF & _
"123456781234567812345678.11"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)