using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^)(?=(?:\d{3})+(?!\.|\d))";
string substitution = @",";
string input = @"123456789123456789123456789
123456789
1234567
123456781234567812345678.11";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}