re = /%(?P<hash_string>[a-zA-Z_]+)\s?=(?:\s+)?(?P<hash_value>\(.*?\))/
str = '%some_hash =
(
...
)
%some_other_hash =
(
...
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end