import Foundation
let pattern = #"Zapp\s+\((.*?)\s+// defaultParameterValue\s+,\s+"(.*)"\s+\/\/\s+name\s+,\s+(.*?)\s+\/\/\s+min\s+,\s+(.*?)\s+\/\/\s+max\s+,\s+(.*?)\s+\/\/\s+d.p.'s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
new Zapp (0.89f // defaultParameterValue
, "A name" // name
, 0.1 // min
, 0.5 // max
, 2 // d.p.'s to show
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Zapp (NormalisableRange<float> ($3, $4) ,NormalisableRange<float> ($3, $4).convertTo0to1($1) , "$2" // name , $5 // d.p.’s"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}