import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#begin regex\n"
+ "(?:\n\n"
+ "#artist\n"
+ "(?:\n"
+ "(.*?)\n"
+ "#end artist\n"
+ ")\n\n"
+ "#feat\n"
+ "(?:\n"
+ "(?:\\s?[(]?\\s?\n"
+ "(?:(?:featuring|feat|ft)(?:\\.?\\/?)(?:\\s?)\n"
+ "(?:(.*?)\n"
+ "(?:\\s?[)]?\\s?\n"
+ "#end feat\n"
+ ")))))\n"
+ "#feat closed\n\n"
+ "#title\n"
+ "(?:\n"
+ "(?:\\s?[-)]\\s?\n"
+ "(?:(.*?)\n"
+ "#end title\n"
+ ")?)?)\n"
+ "#title closed\n\n"
+ "#remix\n"
+ "(?:\n"
+ "(?:\\s?[(]\\s?\n"
+ "(?:(.*?)\n"
+ "(?:\\s?[)]\\s?\n"
+ "#end remix\n"
+ "))))\n"
+ "#remix closed\n\n"
+ "#post-feat\n"
+ "(?:\n"
+ "(?:.*?\n"
+ "(?:\\s?[(]?\\s?\n"
+ "(?:(?:featuring|feat|ft)(?:\\.?\\/?(.*?))\n"
+ "(?:\\s?[)]\\s?\n"
+ "#end post-feat\n"
+ ")?)?)?)?)$\n"
+ "#post-feat closed\n\n"
+ "#end regex\n"
+ ")$\n"
+ "#regex closed";
final String string = "Bakermat (feat. Kiesza) - Don't Want You Back (Extended Mix) feat kesha";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}