const regex = /\b(^\w+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(^\\w+)', 'mg')
const str = `While the patient had received travel vaccinations in preparation for a trip to India two years ago, it was not immediately certain that he received the meningococcal vaccine.
Investigation is ongoing, and this report will be updated as more information becomes available.
Reported by:
?lvaro Mej?a-Echeverry`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);