import Foundation
let pattern = #"\b(^\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
While the patient had received travel vaccinations in preparation for a trip to India two years ago, it was not immediately certain that he received the meningococcal vaccine.
Investigation is ongoing, and this report will be updated as more information becomes available.
Reported by:
?lvaro Mej?a-Echeverry
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)