$re = '/([\w\d.-]+)@(\w+\.\w+)(\.\w+\?)/';
$str = 'info@gmxperfekt.ch
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);