$re = '/<(textarea)[^>]+>[^%]*?<\/\1>/';
$str = '<p>
<textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">
<p>5051950 á</p>
</textarea>
</p>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">teste á teste teste teste teste</textarea></p>
<p><textarea class="ckeditor-basic" cols="100" name="textAreaName" required="required" rows="5">é</textarea></p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);