using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p\b[^<>\/]*>\s*(<img\b[^<>]*>)\s*<\/p>";
string substitution = @"$1";
string input = @"<p class=""text"">test</p><p class=""image""> <img src=""vvv"" /> </p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}