$re = '/(?i)(EDIResources\/EDITradingPartnerUpdates\/tabid((?:(?!\?).)*))(.*)/i';
$str = 'www.1edisource.com/ediresources/editradingpartnerupdates/tabid=123
www.1edisource.com/ediresources/editradingpartnerupdates/tabid=123?gclid=jjj
www.1edisource.com/ediresources/editradingpartnerupdates/tabid
www.1edisource.com/ediresources/editradingpartnerupdates/tabid?gclid=jjj';
$subst = "category/trading-parter-update$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;