#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)xxx(?!(.*STRING1.*))xxx"
Local $sString = "xxxxxx" & @CRLF & _
"xxxSTRING1xxx" & @CRLF & _
"xxxSTRING2xxx" & @CRLF & _
"xxxSTRING3xxx" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"import org.apache.spark.rdd.RDD" & @CRLF & _
"" & @CRLF & _
"df.rdd" & @CRLF & _
" .map" & @CRLF & _
"" & @CRLF & _
"df.rdd." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")