using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"xxx(?!(.*STRING1.*))xxx";
string input = @"xxxxxx
xxxSTRING1xxx
xxxSTRING2xxx
xxxSTRING3xxx
import org.apache.spark.rdd.RDD
df.rdd
.map
df.rdd.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}